Saturday, March 14, 2009

my "big" ultrasound should not have gone like this...

I had my big ultrasound this morning, and things did not go well. The tech immediately asked me if I had been leaking amniotic fluid, which I said no, because I haven't noticed anything strange. She then wouldn't tell me what was going on, so I cried all the way through it. She finished getting the shots she wanted and asked me to wait there while she called my doctor. Thank god my mom and Will were there, or I would have been hysterical. I heard her on the phone with the doctor and heard her say, with emphasis, a few times, the words 'zero" and "none". Then she asked me to get on the phone with him.

Turns out I have very little amniotic fluid right now, so the doc put me on modified bed rest at home for the weekend, drinking plenty of water. Monday I am not supposed to go in to work,, and call the office at 9am to get my referral to a specialist for another ultrasound. If the fluid levels have gone up, I may be able to go to work and just be on pelvic rest. If they DON'T, then I may be looking at a hospital stay to pump me full of IV fluids.

To top it off, baby was facing my back, and with no fluid, it was very hard for her to get even a clear shot of an arm, so I saw nothing of my baby at all. the only thing I DO know is the heart rate was 157. No pictures, no gender.

It was a disappointing day all around.

1 comment:

  1. Oh Jamie. How very, very upsetting and traumatic for you. I am so sorry you are going through this right now. I know it cannot be easy. I just wanted to let you know that someone out there is reading your story and her heart is breaking for you, your Hubby, and your dear, sweet baby. My thought are with you. I am so very sorry you have to go through this. Huge hugs.